Cisco IOS XE Release 3.6E (Catalyst 3650 Switches)

Cisco IOS-XE No Longer Uses Trunk Encapsulation Dot1q

I have a pair of Cisco Catalyst 3650X-48TS switches running IOS 12.2(55) and when using trunk encapsulating dot1q from the router to the switch, and then, to the client, Cisco decided to change the commands.

For example, I want to pass two VLANs from the switch to my ESXi hosts. VLAN 11 is the native VLAN (i.e. VMKernel network) that will be used to connect to VMware vSphere Client while, VLAN 12 is the vMotion network.

IOS 12.2(55) Example – Trunk Encapsulation Dot1q
——————————————————————

switch# sh run int gi0/7

  interface GigabitEthernet0/7
   description AZ-R630-3-LOM3
   switchport trunk encapsulation dot1q
   switchport trunk allowed vlan 11,12
   switchport mode trunk
   spanning-tree portfast trunk
  !

——————————————————————
On newer switches, like my pair of Cisco Catalyst 3650-48TS running IOS XE 3.3, the untagged VLAN uses the native VLAN command. VLAN 11 is the VMKernel network (Native VLAN).

IOS-XE 3.3 Example – Without Trunk Encapsulation Dot1q
——————————————————————

switch# sh run int gi1/0/7

  interface GigabitEthernet1/0/7
   description AZ-R630-3-LOM3
   switchport trunk native vlan 11
   switchport trunk allowed vlan 11,12
   switchport mode trunk
   spanning-tree portfast trunk
  !

——————————————————————

It took me like 8 hours of research on Cisco Support forums to find this gem. Apparently, according to Cisco Support you cannot set the encapsulation. However, the switch does support 802.1q

https://supportforums.cisco.com/discussion/12879676/cisco-3650-and-8021q-encapsulation

 

Resources

For more information about VLAN tagging click below.
Why and how are Ethernet Vlans tagged?
http://networkengineering.stackexchange.com/questions/6483/why-and-how-are-ethernet-vlans-tagged

Catalyst 2960 and 2960-S Software Configuration Guide, 12.2(55)SE
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960/software/release/12-2_55_se/configuration/guide/scg_2960/swvlan.html

VLAN Configuration Guide, Cisco IOS XE Release 3.6E (Catalyst 3650 Switches)
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3650/software/release/3e/vlan/configuration_guide/b_vlan_3e_3650_cg/b_vlan_3se_3650_cg_chapter_0100.html

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s